Scheduled Backup dialog does not close.

Submitted 9/30/2010 by Scott Mckeown

This occurs when the scheduled backup time is not set or set to 0. Klok essential always thinks its time to run a backup. This is an issues that has been fixed with the Klok 2.2.2 update.

To correct the problem:

Close  Klok.

Then open the preferences file which is stored in different locations depending on your OS.

Windows XP:
C:\Documents and Settings\[User Name]\Application Data\Klok2.DD7F2188B985C2439837C76B42A187050457E61B.1\Local Store

 

Windows Vista/Win 7:

C:\Users\[User Name]\AppData\Roaming\Klok2.DD7F2188B985C2439837C76B42A187050457E61B.1\Local Store

Mac OSX

 

user/Library/Preferences/Klok2.DD7F2188B985C2439837C76B42A187050457E61B.1/Local Store

Inside that folder you will find a file called config.xml. If you open that file in notepad, you will see that contents of it. Inside it, you will find a line that contains this:

<backup-delay>0</backup-delay>

Change the 0 (or if there is any value less than 1) to a 7 and save your file. Then reopen Klok and you should be back in business.